Skip to content

常见问题

更多常见问题请参考赋能平台知识库

1.通用模板,关系型数据库同步,当源库MySQL表的字段为NULL值时,报错 Unable to get timestamp from resultset at index 6

Snipaste_2025-08-08_14-19-02

解决方案

在公共资源,数据源管理,MySQL数据源配置连接参数 serverTimezone=Asia/Shanghai和zeroDateTimeBehavior=CONVERT_TO_NULL。

若是在数据源配置后添加的参数,需在数据开发的项目配置—数据源配置,刷新数据源。

Snipaste_2025-08-08_14-29-56


2.dolphin启动报错Factory method 'storageOperate' threw exception; nested exception is java.nio.file.AccessDeniedException: /dws

Snipaste_2026-03-26_13-53-03

原因分析

Dolphin 进程没有对 /dws 目录的读写权限或 /dws目录不存在。

解决方案

第一步:停止 Dolphin 服务(dolphin以standlone为例),切换到dws用户

bash
./stop-standalone.sh

方案一:保留原目录 /dws,修复权限

  1. 创建目录(如不存在)

    bash
    sudo mkdir -p /dws
  2. 修改所有者和权限

    bash
    sudo chown -R dws:dws /dws   # 授权为实际启动dolphin的用户组权限
    sudo chmod -R 755 /dws
  3. 重启服务

    bash
    ./start-standalone.sh

方案二:更换存储目录

  1. 修改配置文件 编辑 Dolphin 配置文件dolphin/standalone-server/conf/common.properties,找到存储路径配置项(dolphin以standlone为例),例如:
    yaml
    resource.storage.upload.base.path=/dws
    改为新路径,如 /home/720DWS/dws,示例如下:
    yaml
    resource.storage.upload.base.path=/home/720DWS/dws

Snipaste_2026-03-26_13-53-05

Snipaste_2026-03-26_13-53-04

  1. 创建新目录并授权

    bash
    sudo mkdir -p /home/720DWS/dws
    sudo chown -R dws:dws /home/720DWS/dws    # 授权为实际启动dolphin的用户组权限
    sudo chmod -R 755 /home/720DWS/dws
  2. 重启服务

    bash
    ./start-standalone.sh

验证

启动后检查日志,确认无 AccessDeniedException 报错。


3.如何关闭zookeeper默认管理端口admin.serverPort=8080

image_20240927174620

解决方案

  1. 配置

在zookeeper/bin/zkServer.sh中添加-Dzookeeper.admin.enableServer=false image_20240927174952

  1. 验证

image_20240927174639