⌘CtrlK
Appearance
Appearance
更多常见问题请参考赋能平台知识库

解决方案:
在公共资源,数据源管理,MySQL数据源配置连接参数 serverTimezone=Asia/Shanghai和zeroDateTimeBehavior=CONVERT_TO_NULL。
若是在数据源配置后添加的参数,需在数据开发的项目配置—数据源配置,刷新数据源。


原因分析:
Dolphin 进程没有对 /dws 目录的读写权限或 /dws目录不存在。
解决方案:
./stop-standalone.sh方案一:保留原目录 /dws,修复权限
创建目录(如不存在)
sudo mkdir -p /dws修改所有者和权限
sudo chown -R dws:dws /dws # 授权为实际启动dolphin的用户组权限
sudo chmod -R 755 /dws重启服务
./start-standalone.sh方案二:更换存储目录
resource.storage.upload.base.path=/dws/home/720DWS/dws,示例如下:resource.storage.upload.base.path=/home/720DWS/dws

创建新目录并授权
sudo mkdir -p /home/720DWS/dws
sudo chown -R dws:dws /home/720DWS/dws # 授权为实际启动dolphin的用户组权限
sudo chmod -R 755 /home/720DWS/dws重启服务
./start-standalone.sh验证
启动后检查日志,确认无 AccessDeniedException 报错。

解决方案:
在zookeeper/bin/zkServer.sh中添加-Dzookeeper.admin.enableServer=false 
